ChMS: Elvanto - Selecting a payment method is not allowing batches report to run correctly.
Incident Report for Tithe.ly
Update
We are continuing to investigate this issue.
Posted Aug 27, 2021 - 11:02 PDT
Investigating
We are currently investigating this issue.
Posted Aug 27, 2021 - 11:01 PDT